西安人的城墙下,是西安人的火车

美国主机切换php版本教程

上一篇文章讲到phpweb升级到PHP5.3以后都不能正常使用,所以我找办法降版本至5.2,降版本成功,phpweb网站的所有页面都可以正常使用,网上找到以下几个办法,汇总下:

您可以登录cPanel空间面板查看具体的版本信息。在cPanel面板左边点击“Stats”或者点击“expand stats”:展开后在下面就可以找到默认的PHP版本信息。如下图所示(默认PHP版本是PHP 5.4.29):

php版本

美国主机默认php版本

方法一、通过cPanel面板切换PHP版本

1)登录cPanel空间面板,在“高级”模块下面点击进入“PHP Configuration”

php版本配置

php版本配置

2)如下图所示顺序依次进行设置,单击文件夹public_html,后面下拉框中选择PHP版本(截图中是选的PHP 5.2,根据您自己的需要选择相应的版本),然后点“更新”按钮保存设置即可。

php版本配置2

php版本配置2

注:给文件夹public_html设置PHP版本后这个空间上所有的网站都会使用您设置的PHP版本,如果您只是想对空间上的某一个网站设置不同的PHP版本,那就只能对public_html里面那个网站对应的文件夹进行设置(如您空间上有xyz.com和abc.com两个网站,您只想把abc.com这个网站的PHP版本设置为PHP 5.5,那么我们首先是点击public_html文件夹,然后点击abc.com那个文件夹,然后在下拉框中选择PHP 5.5,再点更新)。

方法二、通过.htaccess文件切换PHP版本

除了上面cPanel面板切换PHP版本这种方法外,您还可以通过.htaccess文件来设置PHP版本,具体方法如下:

# Use PHP 5.5
AddType application/x-httpd-php55 .php

将以上代码复制到您网站根目录下面的.htaccess文件即可,注意修改版本,上面示例代码是以设置为PHP 5.5为例,如果是其他PHP版本,则只需要修改x-httpd-php55 .php,如用PHP 5.2则改为x-httpd-php52 .php等。

如果以上代码无效,可以将代码中的AddType改为AddHandler试下;

原创文章如转载,请注明本文链接:西秦记 » 美国主机切换php版本教程

分享到:更多 ()

评论 抢沙发

评论前必须登录!

 

专注于中小企业信息化解决方案

联系我们